[coreboot] coreboot Digest, Vol 46, Issue 148

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Wed Jan 7 13:54:35 CET 2009

On 07.01.2009 13:49, Uwe Hermann wrote:
> On Fri, Jan 02, 2009 at 10:15:32AM +0000, Daniele Primon wrote:
>> Hi, obrain a similar output when trying to flash a proprietary BIOS.
>> What I guess is that the initial address could be wrong. Here is the
>> output:
>> root at debian:~# flashrom -w -v A6T-ASUS-0706.ROMCalibrating delay
>> loop... OK.No coreboot table found.Found chipset "NVIDIA MCP51",
>> enabling flash write... OK.Found chip "PMC Pm49FL004" (512 KB) at
>> physical address 0xfff80000.Flash image seems to be a legacy BIOS.
>> Disabling checks.Programming page: 0007 at address:
>> 0x00070000Verifying flash... FAILED!  Expected=0xf8, Read=0x68
> Are you sure your board is supported by flashrom, or works without
> special support? See http://www.coreboot.org/Flashrom#Supported_mainboards
> Also, have you tried the command multiple times (e.g. 5 times) in a row?
> Sometimes there are glitches and writing will not work, but on the next
> run it will...

Although I claimed back then that MCP51 support worked, that may have
been an error. So far I am aware of no reproducible flashing of any chip
on MCP51.



More information about the coreboot mailing list