[coreboot] coreboot on s4882?

David Melik dchmelik at gmail.com
Fri Feb 6 12:21:31 CET 2009

On 2/6/09, Myles Watson <mylesgw at gmail.com> wrote:
> Do you have a null-modem cable?  Did you see anything on the serial
> console?

I have such cables; maybe not a serial console, but away from university I
have some old analog monitors....

[...] if you grep the source for post_code you'll find some.

Good.  I will try this weekend.

What size is your coreboot.rom (ls -l)?  What size is your chip?
> That's a frequent problem.  If you had to add another ROM, did you
> prepend it?

The .rom (saved on a WD 24000 that Slackware 10.2 cannot mount) size had
'5:' over 512 Kb I guess. The manual says 4 MB.  Apparently my ROM is too
small... I doubt I need certain grub2 modules, but I know not what others

Would it help Coreboot more if I make a smaller grub2 to test newer
coreboot2 on s4882 asap or if wait a while and 'prepend' (if it involves
soldering that is alright.)  I know It can be specially configured; maybe
that needs more ROM.

 Have you tried it with a warm reset?  It's a bit of a long shot, but
> it can affect things sometimes.

I think I at least tried or also turned it on later 1 - 3 times.

It is very unlikely that it is reaching the payload.  [...]  Grub2 from
> buildrom works well as long as you substitute ata for hd in the
> grub.cfg.

I may try but would like to try serial consoles:

> I neither want to re-flash [old] BIOS nor yet try coreboot on my alternate
> > Slackware system[....]

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20090206/be99ba0e/attachment.html>

More information about the coreboot mailing list