[coreboot] Problems porting H8dmr_fam10 to H8qme-2+

Myles Watson mylesgw at gmail.com
Wed Dec 23 23:20:31 CET 2009

> > Scan for VGA option rom
> > Got ps2 nak (status=51); continuing
> > ps2_recvbyte timeout
> >
> > I can't see your VGA ROM getting run anywhere.  Did I just miss it?
> Nop, not working anywhere seems like Seabios doesn't find any vga rom.
You could try a more verbose setting for SeaBIOS and send the output to
Kevin.  I'm surprised it doesn't just work.

> So I tried setting up CONFIG_SB_HT_CHAIN_ON_BUS0 to different values, no
> luck!
Yeah.  It doesn't seem like an enumeration problem.  The device tree seems
like it's getting set up pretty well.

> > You could try having Coreboot run it with vm86 and with
> > CONFIG_CONSOLE_VGA set to see if that works.  I'm wondering why
> > SeaBIOS isn't finding it.
> >
> CONFIG_CONSOLE_VGA was already set to 1. How do I run coreboot with vm86?
In Kconfig there's a VM86 option, but I don't see it in newconfig.

> At least now at linux boot up my NICs are found but trying to initialize
> they got to a "Unable to allocate interrupt" :( I attach my latest log.
Did you change the mptable and irqtables to match the factory assignments?

> Now, I wishing all of you a merry merry XMAS and have some nice holidays.
> I hope Santa, or who ever, brings you a whole bunch of new boards ;).
Thanks.  Merry Christmas to you too.


More information about the coreboot mailing list