[coreboot] Coreboot fails to initialize on ASUS A8V-E SE

Knut Kujat knuku at gap.upv.es
Fri Dec 11 11:22:25 CET 2009

Rudolf Marek escribió:
> Hi,
> Can you test with revision 3593?
> I think you will need to do - buildtarget stuff ;)
> Rudolf

It fails compiling and don't know exactly why:

gcc -m32  -nostdlib -nostartfiles -static -o coreboot -T ldscript.ld crt0.o
nm -n coreboot | sort > coreboot.map
objcopy --gap-fill 0xff -O binary coreboot coreboot.strip
gcc -o buildrom
cp /home/knuku/bios.bin.elf payload
./buildrom coreboot.strip coreboot.rom payload 0x20000 0x40000
coreboot.strip: Value too large for defined data type
make[1]: *** [coreboot.rom] Error 2
make[1]: se sale del directorio
make: *** [normal/coreboot.rom] Error 1

I did:

./buildtarget asus/a8v-e_se
cd asus/a8v-e_se
(set the right path to the payload in Config.lb)
cd asus_a8v-e_se

I tried with the same payload I did with the newer revisions filo.elf
and then I tried a already compiled seabios elf.

Knut Kujat

More information about the coreboot mailing list