[coreboot] GeodeLX RAM initialisation issue

ron minnich rminnich at gmail.com
Fri Dec 4 18:03:14 CET 2009

On Fri, Dec 4, 2009 at 8:47 AM, Daniel Mack <daniel at caiaq.de> wrote:
> No hint, anyone?

Just about every time I had this problem on my geodes it was a problem
with dram. Just about every time. It's quite weird how well DRAM can
work even if it has not been programmed correctly. The correspondance
with disable_car() might just be that there's lots of burst cache
traffic to ram when you do this operation and cache is suddenly
connected to dram again.

Also, over the years, we have frequently found that DRAM vendors are,
well, less-than-honest about their product. One experience was on
OLPC. We had three boards, all with nominally the same parts,
different vendors however.
Boards A&B worked with faster timing; Boards A&C worked with medium
timing; and boards B&C only worked with the slowest timing. (I believe
in this case it was ras to cas delay)

Yes, indeed, it's not always true that slowing down dram makes it work :-)

Rather than "power off for 10 minutes" -- I assume this is "at the
wall plug" -- I wonder if you'd see an improvement if you yanked the
DC power at the board. Which were you doing -- AC or DC power off?



More information about the coreboot mailing list