[coreboot] Problem jumping to Boot Loader

Jeffrey C. Jacobs jacobs at itd.nrl.navy.mil
Thu Aug 6 17:53:52 CEST 2009

Patrick et al.,

Thanks again for the help and advice.  Rudolf, I may try to look into 
your solution since I too am trying to boot off an ext3fs system but 
Patrick you have been a great help so far.  I don't as a rule manually 
edit .config scripts, they're just convenient for reviewing settings. 
Actually, I used "make menuconfig", which is what is suggested in the 
FILO README, but that did not seem to generate build/config.h correctly 
so I tried the basic "make config" as you suggested and that seems to 
have generated the correct build.

So I loaded up my CoreBoot+FILO payload and booted and got the result 
listed in: http://coreboot.pastebin.com/f432f39bc

Now, with all those ANSI Escape Codes, I tried to clean up the last bit 
which has my FILO prompt and output: http://coreboot.pastebin.com/f7cb33b5

It's probably so busy because I have all the debugging output turned on. 
  All that said, the bad news is that I still can't boot and it looks 
like it still doesn't recognize my hard drive.  I've highlighted a few 
lines that I think may be relevant.  Firstly, we have:

ERROR: No such CMOS option (boot_devices)
menu: hda1:/boot/filo/menu.lst

I guess we can safely ignore the first line since we've not AFAICT 
entered the IDE probe yet and the second line just reiterates the 
menu.lst location.

There follows a series of probes of memory addresses which are mostly 
uneventful.  The exception is a failure to access the bridge at 01:09.00:

Misconfigured bridge at 01:09.00 skipped.

It seems to reprint this each time it tries to scan that memory area. 
I'm not sure what this represents, but I guess it's okay to ignore for 
the time being.

Finally, we have a better description of my error:

found PCI IDE controller 8086:24cb prog_if=0x8a
primary channel: compatibility mode
skipping 0 native PCI controllers, new index=0
cmd_base=0x1f0 ctrl_base=0x3f4
init_controller: drive 0
Detected floating bus
No drive detected on IDE channel 0
Failed to open IDE.
dev=hda1, path=/boot/filo/menu.lst
Drive 0 does not exist
Failed to open IDE.
Could not open menu.lst file 'hda1:/boot/filo/menu.lst'. Entering 
command line.

So I get this "No drive detected on IDE channel 0", which implies to me 
it's something lower-level that the file system.

So, does anyone have any better idea, given this new information, why 
this version of FILO can't detect my hard drive?

Thanks in Advance!


Patrick Georgi wrote:
> Jeffrey C. Jacobs schrieb:
>> Danke vielmals Patrick and many thanks to everyone else,
>> So, I decided to take your advice about switching (back to) FILO using
>> the latest version (svn 103) and latest libpayload (svn 4505) but am
>> still having problems recognizing my First Partition on the Primary
>> Master IDE device, namely hda1.  Specifically, using the FILO build
>> settings specified here: http://coreboot.pastebin.com/f4e644a72
> How did you change that configuration, simply by editing .config, or by
> going through the "make config" routine?
> Editing .config doesn't adapt the files in build/, so it should always
> be completed with a "make oldconfig" (and then look if it took your
> values or overwrote it with something else due to dependencies)
> To be extra careful, always run "make clean" after changing the
> configuration to force a full build.
>> Anyway, since my menu.lst could not be loaded, I typed in the full
>> boot command replete with kernel boot parameters, and as you can see I
>> got a generic error stating that FILO could not find Device 0
>> (obviously meaning it could not find hda1).  So, I'm not sure if this
>> is a problem with FILO, but it seems much more likely I have some
>> errant settings in Coreboot which is not allowing FILO to see my
>> drives.  Does anyone have any ideas?
> The device numbering might be weird at times. It's reasonably stable
> once you found the right device name, but it can differ from what you
> see elsewhere, so try hdb, hdc, and hdd, too.
> Patrick

More information about the coreboot mailing list