[coreboot] v2: The elfboot process with 128MB RAM

Joseph Smith joe at settoplinux.org
Sat Sep 6 15:15:12 CEST 2008

On Sat, 06 Sep 2008 14:19:37 +0200, Mats Erik Andersson
<mats.andersson at gisladisker.se> wrote:
> Joseph Smith <joe at settoplinux.org> skrev s vnligt:
>>> Thus, I am now trying to understand why a large amount of memory,
>>> i.e., 128MB instead of a mere 64MB, can prevent elfboot to succeed,
>>> even though the memory is undisputably well initialised.
>>Hmm, I still have a feeling your memory is not initializing correctly.
> Have
>>you tried ram_check() (from auto.c) on various chucks of memory? I would
> I did use these ram checks (last line was active for my last message):
> 	/* DOS-area */
> 	//ram_check(0, 640 * 1024);
> 	/* 1MB to 4MB */
> 	//ram_check(0x00100000, 0x00400000);
> 	/* Across 64MB boundary */
> 	//ram_check(0x03fff000, 0x04000010);
> 	/* Just below 128MB */
> 	ram_check(0x07ffff00, 0x07fffff0);
> Now that I have prepared accurate SPD-dumps for seven SDRAM cards,
> I will return on Monday to perform more extended verifications.
> Possibly large memory chunks could tell me more than strategic
> sampling does. The bad thing is that the code space prevents more
> than one verification range in each build, so the pace is indeed slow.
Another thought...have you tried booting to memtest? If you can, memtest
will absolutly be able to tell you what is going on here.

Joseph Smith

More information about the coreboot mailing list