[coreboot] AVATT got false alarm

Cristi Magherusan cristi.magherusan at net.utcluj.ro
Tue Sep 2 00:56:08 CEST 2008


On Mon, 2008-09-01 at 18:19 -0400, Joseph Smith wrote:
> Exellent news Cristi:-)
> Have you tried any Linux Distros yet?

Sorry, but it turned out that it was a false alarm. 

I ran by mistake qemu in 32bit mode and this way kvm from inside it was
running as plain qemu, because it was missing the virtualization
instructions available only if the hosting qemu emulates 64bit CPUs.

Plain qemu should work, since the TLS stuff is used inside kvm only in
the libkvm code which is skipped if those instructions are missing. 

Anyway, the fact that kvm worked this way and didn't crash at startup
confirmed once again that TLS is the missing piece and makes me even
more motivated to get it done.

Best regards,

Ing. Cristi Măgherușan,
Universitatea Tehnică din Cluj-Napoca
Centrul de Comunicații "Pusztai Kalman"
Tel. 0264/401247  http://cc.utcluj.ro
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080902/3a169c40/attachment.sig>

More information about the coreboot mailing list