[coreboot] [PATCH] v2: Revert i945/ICH7 PCI ID #define usage

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Oct 31 11:43:07 CET 2008

On 31.10.2008 11:27, Uwe Hermann wrote:
> Hi,
> As there's obviously no consensus on whether or not to use #defines for
> PCI IDs in 'struct pci_driver' fields (I hope that we all _do_ agree
> that #defines are _usually_ better for readability, except in some rare
> cases), I suggest we declare this as a matter of taste and accept both
> variants in svn, depending on the preferences of the author of the
> code (Stefan in this case).
> Thus, here's a patch to revert i945/ICH7 back to hard-coded numbers.

Acked-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>



More information about the coreboot mailing list