[coreboot] [PATCH] v2: Revert i945/ICH7 PCI ID #define usage

Uwe Hermann uwe at hermann-uwe.de
Fri Oct 31 11:27:30 CET 2008


As there's obviously no consensus on whether or not to use #defines for
PCI IDs in 'struct pci_driver' fields (I hope that we all _do_ agree
that #defines are _usually_ better for readability, except in some rare
cases), I suggest we declare this as a matter of taste and accept both
variants in svn, depending on the preferences of the author of the
code (Stefan in this case).

Thus, here's a patch to revert i945/ICH7 back to hard-coded numbers.

http://www.hermann-uwe.de  | http://www.holsham-traders.de
http://www.crazy-hacks.org | http://www.unmaintained-free-software.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: v2_revert_pciids_defines.patch
Type: text/x-diff
Size: 10202 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20081031/57b112a7/attachment.bin>

More information about the coreboot mailing list