[coreboot] v3 comments - was Serengeti vga hang

Marc Jones Marc.Jones at amd.com
Wed Oct 15 19:36:32 CEST 2008

Myles Watson wrote:
> Here's the latest log.  It hangs in the emulator.  I've tried both 
> emulators, but to no avail.
Nothing jumped out at me why you might be having a problem with VGA.

These are some general v3 comments. I have a good feel for the new 
dts/device scanning so some questions may just be dumb.

> setting up resource map ex offset....
> (0+0,18+0,1+0,44) & 0000f8f8 | 00000000+00000000
> (0+0,18+0,1+0,4c) & 0000f8f8 | 00000001+00000000
> done.

I don't think that resource setup needs to be done this early. There are 
  no resources before HT init. It should go just before:
Ram1.0, setting up CPU 0x00 northbridge registers

> Choosing fallback boot.
> LAR: File not found!
> LAR: Run file fallback/initram/segment0 failed: No such file.
> Fallback failed. Try normal boot
> LAR: Attempting to open 'normal/initram/segment0'.

I think that this came up way back when, but why is fallback tried 
first? Is this a configuration mistake? It is a waste of time which is 
making SimNow take even longer.

> prepare to InitDram:00000000000000010000000200000003000000040000000500000006000000070000000800000009

That is some strange output....

> find_device_operations: cons 0x00015260, cons id PCI: 1022:1100
> find_device_operations: check all_device_operations[i] 0x00015800
> dev_id_string: Unknown device ID type: 0
> find_device_operations: cons 0x00015800, cons id Unknown …À‰ÁÆÀ¤
> constructor: constructor is 0x00000000
> No ops found and no constructor called for PNP: 0000.
> new_device: devcnt 4
> find_device_operations: check all_device_operations[i] 0x00015200

This is the CPU HT device.  This section loops several times. What is 
coreboot trying to do?

And then some stuff gets setup and it loop some more...
Yeah, keep seeing this output come up again and again.

> PCI: scan devfn 0xc0 to 0xff
> PCI: devfn 0xc0

What is this for? When scanning PCI stuff

> PCI: devfn 0xc4
> pci_scan_get_dev: list is 0x000cf084, *list is 0x00016680
> pci_scan_get_dev: check dev domain_0_pci_1_0 
> pci_scan_get_dev: check dev domain_0_pci_1_0 it has devfn 0x08
> pci_scan_get_dev: check dev domain_0_pci1_18_0 
> pci_scan_get_dev: check dev domain_0_pci1_18_0 it has devfn 0xc0
> pci_scan_get_dev: check dev domain_0_pci2_18_0 
> pci_scan_get_dev: check dev domain_0_pci2_18_0 it has devfn 0xc0
> pci_scan_get_dev: check dev domain_0_ioport_2e 
> pci_scan_get_dev: child domain_0_ioport_2e(IOPORT: 2e) not a pci device: it's type 11
> pci_scan_get_dev: check dev dynamic PNP: 002e.0

When scanning for PCI devices PNP IO areas should probably be skipped or 
I may just misunderstand what it is doing here...

Where is phase4_enable_disable? Shouldn't it happen before Phase 4: 
Reading resources ?

There is some 8111/8132 setup that might be causing the VGA issue?


Marc Jones
Senior Firmware Engineer
(970) 226-9684 Office
mailto:Marc.Jones at amd.com

More information about the coreboot mailing list