[coreboot] alix.2c3 stops at mainboard_pre_payload: done

Peter Stuge peter at stuge.se
Thu Oct 9 15:46:00 CEST 2008

Roman Yeryomin wrote:
> > I don't see the "mainboard_pre_payload" message at all, even
> > though it is in alix1c/stage1.c just like alix2c3/stage1.c.
> so why is it appearing at all?

I would expect it to always appear. I think it's a bug that it
doesn't appear for me when using the ELF loader.

> > You could try first without preparsing the payload, and then try a
> > few different payloads. What are you currently using?
> already tried not to preparse payload, with coreboot-v3 svn it gives
> the same "mainboard_pre_payload" message

That does not match my results. Hmm.

> , just tried with buildrom:
> LAR: load_file: No such file 'normal/payload/segment0'
> LAR: load_file_segments: Failed for normal/payload
> FATAL: No usable payload found.

This is not using the ELF loader, this is trying to load a preparsed

> tried with coreinfo and filo payloads (both buildrom and clean svn)
> what versions/revisions people with working alix.2c3 use?

I'm using FILO r49 or r52 and v3 r909.

Maybe you can try building v3 with the ELF loader enabled and a few
different payloads without using preparsing?


More information about the coreboot mailing list