[coreboot] alix.2c3 stops at mainboard_pre_payload: done

Roman Yeryomin leroi.lists at gmail.com
Wed Oct 8 11:54:44 CEST 2008

On Wednesday 08 October 2008 02:16:44 Peter Stuge wrote:
> Hi Roman,
> Mail Lists wrote:
> > I'm experimenting with alix.2c3 here, but have no luck.
> > I tried coreboot v3 (r870, r898) with filo (r64, r80) and coreinfo
> > (r3640) payloads (with libpayload r3640). All ends up with following:
> >
> > last n-lines snippet (can do full log if it's needed)
> Please do send the full log.

ok, will do as soon as I will get to my alix

> How are you building coreboot?

build payload
get coreboot from svn
make menuconfig
include payload

but seems like I need to try buildrom also...
but anyway... I think it should work like this also, isn't it?

> If you're not using buildrom, you need some LAR know-how because the
> v3 build process is a bit broken in that it does not include the VSA
> into the resulting larball (coreboot.rom) automatically. The magic
> command is:
> lar -C lzma -a build/coreboot.rom amd_vsa_lx_1.01.bin:blob/vsa

of cause I did that
I also tried not to include vsa but it ends up complaining about not finding 
vsa :)

> amd_vsa_lx_1.01.bin needs to be 57504 bytes, if it is smaller you
> need to uncompress it. Downloading
> http://www.amd.com/files/connectivitysolutions/geode/geode_lx/amd_vsa_lx_1.
>01.bin.gz and renaming it to exclude the .gz extension produces the correct
> file here.
> $ md5sum amd_vsa_lx_1.01.bin
> 0f4fd87b3eef78bd90b56a39646f5845  amd_vsa_lx_1.01.bin

0f4fd87b3eef78bd90b56a39646f5845  amd_vsa_lx_1.01.bin


More information about the coreboot mailing list