[coreboot] keyboard tricks in SimNOW?

Jordan Crouse jordan.crouse at amd.com
Fri Oct 3 18:53:40 CEST 2008

On 03/10/08 10:48 -0600, Myles Watson wrote:
> I found a comment in the Serengeti DTS that says it would be nice to look at
> an lspci.  I thought "I can do that pretty easily." 
> I booted a DSL 4.3 CD with the original BIOS and the keyboard doesn't seem
> to work.  I tried the paste text command and couldn't get that to work
> either.  Each keypress and release is logged correctly by the simulator, but
> somehow gets lost.
> I booted with a coreboot + LAB kernel, but there are weird key problems
> there too.  Even though each key shows up correctly in the shell, only a
> random mix of the characters get passed to the shell (most of the times
> every other character.) I was able to do an ls /dev/* by typing llss
> //ddeevv//**, which passed the command once with Enter, then again with the
> next Enter.
> Is there a trick to this?  I'm tried it on SimNOW 4.4.1pub 4.4.2pub and
> 4.4.4pub.

Hmm - I don't know if there is a trick for that or not.  I booted a 
Ubuntu rootfs the other day, and it seemed to work okay, I'll try
to play around and see if I can break it.  I'll send your message
on to the SimNow team to see if they recognize the problem.

I have noticed, however, that the SimNow GUI doesn't take kindly
if I use ctrl-alt-<arrow> to switch workspaces - something about the
control characters seems to confuse it.   Perhaps you are hitting
something similar.


Jordan Crouse
Systems Software Development Engineer 
Advanced Micro Devices, Inc.

More information about the coreboot mailing list