[coreboot] [PATCH] v3: s/BIOS_DEBUG/DEBUG/ etc. for printk()

ron minnich rminnich at gmail.com
Fri Nov 7 00:11:30 CET 2008

On Thu, Nov 6, 2008 at 2:58 PM, Carl-Daniel Hailfinger
<c-d.hailfinger.devel.2006 at gmx.net> wrote:
> On 25.10.2008 13:05, Uwe Hermann wrote:
>> On Fri, Oct 24, 2008 at 03:31:20AM +0200, Peter Stuge wrote:
>>> Uwe Hermann wrote:
>>>> Drop the 'BIOS_' prefix from all printk() log-levels.
>>> It would be nice to have another prefix though. Maybe LOG_ ? Without
>>> a prefix some of the names look a bit too generic.
>> I've though about that, but I don't see it as a big problem. Only
>> "DEBUG" tends to be misused in v2, but we can easily avoid that by
>> using DEBUG_SMBUS, DEBUG_FOOBAR #defines in v3 (if at all; all of
>> those custom DEBUG #defines should be printk()-loglevels anyway;
>> I think the reason for DEBUG in v2 is usually romcc/size relåted(?))
>> If we all desperately want a prefix, how about something really short,
>> e.g. LDEBUG, LWARN, LINFO, ... ? I'd really like to keep the printk()
>> lines as short as possible for readability reasons.
> Can't we just keep the names as they are?

I think the majority prefer that they not change ...


More information about the coreboot mailing list