[coreboot] Gigabyte M57SLI - 4MB Chip - LAB doesn't boot like expected

Harald Gutmann harald.gutmann at gmx.net
Tue May 27 00:19:25 CEST 2008

Am Dienstag, 27. Mai 2008 00:11:44 schrieben Sie:
> On 26.05.2008 23:32, Harald Gutmann wrote:
> > Am Samstag, 24. Mai 2008 20:46:49 schrieb Carl-Daniel Hailfinger:
> > I tried it now to build an image with the playload from the link, but it
> > has the same problem than i've with my coreboot.rom file.
> Thanks for testing.
> > LZMA Error on booting and the scratchpad-size reported with your previous
> > patch is also the same like with the original rom-file from me.
> I'll have to investigate that after LinuxTag. Most important would be a
> runtime check for correct headers. The values you're seeing suggest a
> possible problem with ROM mapping. I suspect it will go away if you use
> an 1 MB image as described below.
> > Is it possible to flash an rom-file with lower file-size than the chip
> > has, and to boot from it? As this would work i'd try to generate a
> > rom-file with 1 or 2MB. My "problem" is, that i've just an 512kB Chip,
> > and the 4MB one, and on 512kB there is too less space for LAB or linux as
> > payload.
> Try creating a ROM file with 2 MB, then run
> cat coreboot.rom coreboot.rom >final.rom
> and flash final.rom. A ROM file with 1 MB would use the following:
> cat coreboot.rom coreboot.rom coreboot.rom coreboot.rom >final.rom
> That should work fine for the ROMsize!=flashsize problem.
Thanks for the fast answer, but i think that just the ROM-SIZE causes a 
problem somewhere.

At the moment i'm building a 2mb rom-file, and try if there is the same error 
with lzma, or if it works like expected.

> Regards,
> Carl-Daniel


More information about the coreboot mailing list