[coreboot] Epia ME6000 VGA

Kevin O'Connor kevin at koconnor.net
Mon May 26 16:54:55 CEST 2008

Hi Michael,

On Wed, May 07, 2008 at 08:51:29PM +0000, Michael Rauscher wrote:
> I ran into problems to enable VGA in coreboot on the ME6000.
> The log:
> coreboot- So 4. Mai 10:09:40 CEST 2008 starting...
>  Enabling mainboard devices
>  Enabling shadow ram
> PCI: 00:11.5 [1106/3059] enabled
> Error! malloc: free_mem_ptr >= free_mem_end_ptr

I ran into this problem also.  I was able to get around it by
modifying src/mainboard/via/epia-m/Options.lb and increasing

default HEAP_SIZE=0x5000

Unfortunately, I still can not get vga output on my epia-m9000.

> device pci 0.0 on  # PCI
>         chip drivers/pci/onboard
>                 device pci 0.0 on end
>                 register "rom_address" = "0xfff80000" #512k image
>         end
> end

I don't think adding this is right.  Looking at the logs, this seems
to cause vga to get initialized twice.  (Unfortunately, I can't get
vga output regardless of how many times it gets initialized.)


More information about the coreboot mailing list