[coreboot] [PATCH] flashrom: something

Joseph Smith joe at settoplinux.org
Fri May 16 17:23:09 CEST 2008

On Fri, 16 May 2008 17:20:40 +0200, Carl-Daniel Hailfinger
<c-d.hailfinger.devel.2006 at gmx.net> wrote:
> On 16.05.2008 15:19, Stefan Reinauer wrote:
>> Carl-Daniel Hailfinger wrote:
>>> OK, I figured one part out:
>>> Drop erase_sector_39sf020() which is an identical copy of
>>> erase_sector_28sf040().
>> Alright. This starts making more sense. I still say NACK, as the name
>> for that function is obviously very wrong then.
>> If the erase sector function works on several chips, even from different
>> generations, it should not carry the name of one specific chip.
>> If we find a good name for it, that makes clear when supporters of new
>> chips can use it, I suggest lets commit your patches.
> OK, I looked at the datasheet and erase_sector_39sf020() is totally and
> completely wrong. It was a straight cut'n'paste from SST 28SF040 code
> and the person doing the cut'n'paste didn't even bother to check the
> data sheet. The SST 39SF020 is completely incompatible with the 28SF040.
> Can I have an Ack for dropping that code?
Are you going to just drop the code or replace it with the correct code??

Joseph Smith

More information about the coreboot mailing list