[coreboot] [PATCH] flashrom: ST M25P40 bug?

Fredrik Tolf fredrik at dolda2000.com
Sat Mar 29 04:42:24 CET 2008

I don't know if this is a bug, or if there are somehow two completely
different versions of the ST M25P40 SPI chip.

I just tried to burn such a chip with flashrom, but it wouldn't detect
it at all, so I checked the datasheet for it, and it turned out that the
probe was completely different from what one would think, reading
flashrom's source.

It seems that the M25P40 doesn't use the RDID command to send its ID,
but rather a "RES" (Read Electronic Signature) command instead, which
returns just one byte. I added support for it, and then it worked
perfectly for me.

I'm attaching my patch to fix the problem. I would imagine that the
other M25Pxx chips would be affected by the same problem, but since I
can neither verify nor test what IDs they would have, they are excluded
from my patch.

Fredrik Tolf

-------------- next part --------------
A non-text attachment was scrubbed...
Name: m25p40.diff
Type: text/x-patch
Size: 3333 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080329/899410dc/attachment.diff>

More information about the coreboot mailing list