[coreboot] libpayload: CMOS / BCD functions

Jordan Crouse jordan.crouse at amd.com
Fri Mar 28 15:42:41 CET 2008

On 28/03/08 10:41 +0100, Stefan Reinauer wrote:
> Uwe Hermann wrote:
> > On Thu, Mar 27, 2008 at 11:21:53PM +0100, Peter Stuge wrote:
> >   
> >> On Thu, Mar 27, 2008 at 09:24:08PM +0100, Uwe Hermann wrote:
> >>     
> >>> I'll follow-up with a coreinfo patch to dump the whole CMOS array.
> >>>       
> >> It would be nice to use NVRAM instead of CMOS. Looks good!
> >>     
> >
> > Hm, yeah, I thought about it, NVRAM is probably the more correct term
> > these days, but the original datasheet (from the 80ies or so) didn't use
> > that and I think the general user base is used to the term CMOS a bit more.
> >
> > I don't care too much, though, I wouldn't object renaming it to NVRAM.
> I vote for nvram, too, especially if we plan going to non-x86
> architectures again. CMOS is really an odd term, I think it got molded
> by the legacy bios vendors over the years.

On the other hand, CMOS is the agreed upon term for x86 platforms - it
sounds stupid to our ears, but we're not typical users.  I would stick
with CMOS.

Regardless of where people think they are going to take coreboot (I have
serious doubts about the usefulness of coreboot on other architectures,
especially the ones being bandied about on the email list), we need to
remember that coreboot is targeted at x86, and thats where all of its
users and potential users will come from for the near future.  We shouldn't
go out of our way to alienate a real x86 user so that we can embrace a 
mythical MIPS user.

Jordan Crouse
Systems Software Development Engineer 
Advanced Micro Devices, Inc.

More information about the coreboot mailing list