[coreboot] [PATCH] libpayload: CMOS / BCD functions
stepan at coresystems.de
Fri Mar 28 10:41:27 CET 2008
Uwe Hermann wrote:
> On Thu, Mar 27, 2008 at 11:21:53PM +0100, Peter Stuge wrote:
>> On Thu, Mar 27, 2008 at 09:24:08PM +0100, Uwe Hermann wrote:
>>> I'll follow-up with a coreinfo patch to dump the whole CMOS array.
>> It would be nice to use NVRAM instead of CMOS. Looks good!
> Hm, yeah, I thought about it, NVRAM is probably the more correct term
> these days, but the original datasheet (from the 80ies or so) didn't use
> that and I think the general user base is used to the term CMOS a bit more.
> I don't care too much, though, I wouldn't object renaming it to NVRAM.
I vote for nvram, too, especially if we plan going to non-x86
architectures again. CMOS is really an odd term, I think it got molded
by the legacy bios vendors over the years.
More information about the coreboot