[coreboot] ICH Series i82801xx EHCI (USB 2.0) problems

joe at smittys.pointclark.net joe at smittys.pointclark.net
Wed Mar 26 20:51:23 CET 2008

Quoting Uwe Hermann <uwe at hermann-uwe.de>:

> On Tue, Mar 25, 2008 at 10:12:29PM -0400, joe at smittys.pointclark.net wrote:
>>> On Tue, Mar 25, 2008 at 06:51:24PM -0400, joe at smittys.pointclark.net wrote:
>>>> I am having a problem getting coreboot->Linux initialize any high
>>>> speed USB 2.0 devices like flash drives. The USB works fine on low
>>> Flash drive? You mean mounting a USB thumb drive? That should work fine,
>>> I tested that on various coreboot boards. Or do you mean an external
>>> IDE/SATA drive which is connected via USB to the computer? I think
>>> both should work fine.
>> Yes neithor of these are working. I have tried USB thumb drives, and a
>> IDE-to-USB 2.0 adapter with hard drive and DVD-rom drive.
> Hm, that's strange, because the thumb drive should work even with
> USB 1.1 only (it sure does on my boards).
that's what I thought, very strange indeed
> Which ports did you try to use? AFAIUI only one or two of them will be
> USB 2.0, the other ones have USB 1.1 speed only, no matter which
> settings the BIOS uses.
> If you can, please test some other high-speed USB device (not thumb
> drives or disks).
>>> Note that AFAICT the USB ports _should_ be intialized ok with coreboot
>>> if the board code is ok, but they might only act as "full speed"
>>> (USB 1.1) devices.
>> Nope USB 2.0 devices (drives) are not detected at bootup, or by hot
>> plugging in Linux. USB 1.1 Keyboards, and mice, work fine.
> Hm, the kernel init _seems_ to look ok to me, but maybe I'm missing
> something.
Yes, that is why I am stumped:-(
> Loading ehci-hcd.ko module
> PCI: Found IRQ 7 for device 0000:00:1d.7
> ehci_hcd 0000:00:1d.7: EHCI Host Controller
> ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 4
> ehci_hcd 0000:00:1d.7: debug port 1
> ehci_hcd 0000:00:1d.7: irq 7, io mem 0xf8180000
> ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00, driver 10 Dec 2004
> usb usb4: configuration #1 chosen from 1 choice
> hub 4-0:1.0: USB hub found
> hub 4-0:1.0: 6 ports detected
> Is the IRQ routing correct?
I think so? I will check this.
> If you attach and use USB devices on those
> ports, do the numbers in /proc/interrrupts increase?
Well for the keyboard and mouse yes, I have not checked it with a USB  
2.0 device, I have not checked that.
>> Not that I am aware, EHCI seems to setup ok in coreboot, except the
>> devices are not detected by coreboot, filo, or Linux.
>>> What exactly does _not_ work btw?
>> When Linux is running and I plug in a USB flash drive, the led on the
>> drive comes on for a few seconds and then turns off, and Linux does not
>> detect the drive. I have tried several different brands. They work fine
>> with the original bios.
> With or without a USB hub? If hub, is it a self-powered hub? Does the
> drive get enough power?
No usb hub. Direct connect.
> Hm, not sure what's going on, maybe someone else can comment?
> It's
> possible that you indeed have to do the init mentioned in the datasheet.
Possible, that is why I asked if anyone else was having this problem  
and/or can confirm it works.

Thanks - Joe

More information about the coreboot mailing list