[coreboot] ICH Series i82801xx EHCI (USB 2.0) problems

joe at smittys.pointclark.net joe at smittys.pointclark.net
Wed Mar 26 03:12:29 CET 2008

Quoting Uwe Hermann <uwe at hermann-uwe.de>:

> Hi,
> On Tue, Mar 25, 2008 at 06:51:24PM -0400, joe at smittys.pointclark.net wrote:
>> I am having a problem getting coreboot->Linux initialize any high
>> speed USB 2.0 devices like flash drives. The USB works fine on low
> Flash drive? You mean mounting a USB thumb drive? That should work fine,
> I tested that on various coreboot boards. Or do you mean an external
> IDE/SATA drive which is connected via USB to the computer? I think
> both should work fine.
Yes neithor of these are working. I have tried USB thumb drives, and a  
IDE-to-USB 2.0 adapter with hard drive and DVD-rom drive.
> To really test USB 2.0 speeds you probably need something like a USB
> DVB-T card (for watching TV) or something similarly fast, I guess.
>> speed USB 1.1 devices like keyboards and mice. I don't think coreboot
>> -> i82801xx_usb_ehci.c is initializing the device correctly. According
>> to the Intel® 82801EB (ICH5), 82801ER (ICH5R), and 82801DB (ICH4)
>> Enhanced Host Controller Interface (EHCI) Programmer?s Reference
>> Manual (PRM) http://www.intel.com/design/chipsets/manuals/298656.htm
>> there are a bunch of steps that the bios is responsible to set this
>> device up. i82801xx_usb_ehci.c is not doing all of these steps. Is
> Correct, none of the code in svn seems to do any special init for EHCI.
> Maybe it's just not required, maybe it _is_ required and nonbody tested
> high speed devices, not sure.
> Note that AFAICT the USB ports _should_ be intialized ok with coreboot
> if the board code is ok, but they might only act as "full speed"
> (USB 1.1) devices.
Nope USB 2.0 devices (drives) are not detected at bootup, or by hot  
plugging in Linux. USB 1.1 Keyboards, and mice, work fine.
>> anyone else using the i82801xx code having any problems with high
>> speed USB 2.0 devices???
> I have this board I could use to test, but it doesn't have EHCI (only
> USB 1.1 ports), so that won't help much, I'm afraid.
Probibly not:-(
> http://www.coreboot.org/ASUS_MEW-AM_Build_Tutorial
> Maybe you can post a full boot log (coreboot + kernel + kernel command
> line options you used) with full debug levels enabled. Are there any
> hints in the log what the problem could be?
Not that I am aware, EHCI seems to setup ok in coreboot, except the  
devices are not detected by coreboot, filo, or Linux.
> What exactly does _not_ work btw?
When Linux is running and I plug in a USB flash drive, the led on the  
drive comes on for a few seconds and then turns off, and Linux does  
not detect the drive. I have tried several different brands. They work  
fine with the original bios.

> Do the USB ports not work _at all_ or
> are they just "slow"?
Yes, they work for low speed USB devices:

usb 1-1: new low speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice
input: Logitech USB-PS/2 Optical Mouse as /class/input/input2
input: USB HID v1.10 Mouse [Logitech USB-PS/2 Optical Mouse] on  
usb 1-2: new low speed USB device using uhci_hcd and address 5
usb 1-2: configuration #1 chosen from 1 choice
input:   USB Keyboard as /class/input/input3
input: USB HID v1.10 Keyboard [  USB Keyboard] on usb-0000:00:1d.0-2
input:   USB Keyboard as /class/input/input4
input: USB HID v1.10 Device [  USB Keyboard] on usb-0000:00:1d.0-2

> Which board is this? RM4100?
Yes the RM4100, you can check out the boot log from the wiki, maybe  
there is a clue? But I did not have a flash drive plugged in then.

Thanks - Joe

More information about the coreboot mailing list