[coreboot] AMD SimNOW Seg Fault

Marc Karasek Marc.Karasek at Sun.COM
Mon Mar 24 17:31:51 CET 2008


Thanks for the offer. I was already in touch with the SimNOW group w/i 
AMD. (Trying all avenues to find a fix)

Turns out it was the max_map_count value being set to low. John Slice 
recommended a value of 8388608 and this works. I have changed my 
sysctl.conf to set this on boot.

Now for the next issue, LAB is failing on linuxrc[1] trap divide error. 
I saw this before and have booted (need to reverify) FILO successfully. 
I had narrowed it down to the Linux and not coreboot, need to debug this 
further to find the problem...


Marc Karasek
Sun Microsystems
mailto:marc.karasek at sun.com

Jordan Crouse wrote:
> On 20/03/08 15:33 -0400, Marc Karasek wrote:
>> I have gotten some cycles and they removed our proxy server 
>> (hurrah!!!).  So I recompiled the BIOS fro SimNOW using buildrom on my 
>> test machine. 
>> When I went to run SimNOW is Seg Faults.  I tried it with the default 
>> BIOS image for the Cheetah BSD, I also tried one of the other BSDs.  All 
>> of them Seg Fault. :-(
>> I made the mistake of updating Fedora8_64 with the latest RPMs.   Lesson 
>> learned, if it ain't broke don't fix it...
>> Does anyone have any idea what, I am guessing, package could be causing 
>> this?  I have tried with both kernels that are on the machine, with no 
>> success.  It did work at one point,  before the update.  I can nuke the 
>> box and reinstall f8_64, but would rather not. 
> See if you can get a core dump and send it to me with the details of your
> system - I'll send it to the SimNow team to see if they can see whats up.
> Also, you can try to send me your ROM and I'll see if I can break it.
> Jordan

More information about the coreboot mailing list