[coreboot] coreboot on QEMU

Bernhard M. Wiedemann corebootbmw2 at lsmod.de
Wed Jun 11 08:44:37 CEST 2008


I have recently tried out the coreboot-v2 trunk with a self-built FILO-0.5 payload and precompiled coreboot-v3+FILO from http://www.coreboot.org/QEMU (bios.bin dating 2008-05-01) using an unpatched qemu-0.9.0 and 0.9.1 from OpenSUSE-10.3. 
The rootfs contained a Debian/Etch that I had lying around.

I encountered some Problems:
a) virtual NIC (ne2k_pci) did not work. It said, it didnt know about IRQ routing for PCI pin A and assigned IRQ 0. pci=biosirq or pci=noapic did not help either.

b) the virtual machine did not power down after "halt"

I verified that both worked by booting Knoppix on the same qemu version without -L (so with standard qemu BIOS)

call was:
qemu -net nic,vlan=0 -net tap,vlan=0,ifname=tap0,script=/etc/qemu-ifup -hda disk.img -L ~ -nographic

Boot Log is at

What for is the qemu-linuxbios/qemu-isa-bios-ram.patch ?
Any other suggestions? 

Bernhard M.

More information about the coreboot mailing list