[coreboot] SeaBIOS debug output

Myles Watson mylesgw at gmail.com
Mon Jul 21 20:44:50 CEST 2008


On Sat, Jul 19, 2008 at 9:51 AM, Kevin O'Connor <kevin at koconnor.net> wrote:

> Hi Myles,
> On Thu, Jul 17, 2008 at 10:40:48AM -0600, Myles Watson wrote:
> > I used to be able to make it through the install process with ADLO
> > (just rombios.c, not rombios32.c), so maybe something in the PCI code
> > is messing me up.
> Okay - that's unexpected.  You seem to be having ps2 port issues - and
> as far as I know that code is the same between seabios and bochs
> bios.

I just tried your latest code, and I'm attaching the logs with and without
PS2 support.  I get an identical blue screen with both of them.  There must
be something else that's stopping the boot.

> Can you list the exact versions you're working with:
> * seabios version

latest from your git repository

> * coreboot version

latest with patches to make it find my coprocessor

* adlo/bochs bios version / source repo

1.186 bochs bios and adlo with patches that I posted to the list.


> I'd like to try and compare the ps2 port code between what works for
> you and what doesn't work for you to try and spot any differences.
> Note that when CONFIG_COREBOOT is on, the PCI code really isn't
> compiled in to seabios.
> > I don't know what else to try.  Hopefully you can spot something in the
> logs.
> I don't see anything obvious.  Are you truncating the logs, or do you
> have disabled the coreboot serial logging?

I was truncating the logs because I have a very verbose boot and it didn't
look relevant.

I saw your post about F7, and since it is silent I couldn't tell if it
worked.  I still saw ACPI-related drivers being loaded.

Have you tried this on Bochs?  When I was doing this before, Bochs failed in
a similar way to the hardware.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080721/7c1f98eb/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: new_seabios.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080721/7c1f98eb/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: new_seabios_no_mouse.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080721/7c1f98eb/attachment-0001.txt>

More information about the coreboot mailing list