[coreboot] flashrom on gigabyte GA-G33-DS3R : success!

Laurence Darby ldarby at tuffmail.com
Sun Jul 20 02:57:46 CEST 2008

Hi Carl,

Carl-Daniel Hailfinger wrote:

> That's interesting. This command does write to the chip without
> erasing first, so the image you now have in ROM is supposed to be a
> mixture of the old and new BIOS. If you haven't tried rebooting yet,
> I'd advise caution.
> Please try to verify the image you just wrote before rebooting.

Ho hum.. 
Well I had extracted the initial bios and compared that with the same
version I downloaded off the website, I found the first 512K matched
md5sums, then there were differences in the second half, and using
'strings', it was just config changes and a record of the motherboard &
cpu it booted on.   So, reading it worked reliably, and for writting, I
thought the only thing that could go wrong is a power cut (yes I should
have UPS).  After the write completed without hicup, I rebooted.

I don't really see how there could be a mixture of versions, shouldn't
one have just cleanly overwritten the other with the file contents?

> > Found chipset "Intel ICH9R", enabling flash write... Can't mmap
> > memory using /dev/mem: Invalid argument
> >
> > linux 2.6.26 has an option for filtering userspace access
> > to /dev/mem, I tried both on and off but that didn't fix it.
> >   
> Ouch. That would be a regression in Linux. Have you tried to report
> this to the linux-kernel mailing list?

No, sorry.  SEP :)


More information about the coreboot mailing list