[coreboot] flashrom on gigabyte GA-G33-DS3R : success!

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sun Jul 20 02:24:18 CEST 2008

Hi Laurence,

On 20.07.2008 01:54, Laurence Darby wrote:
> So I took a huge leap of faith, and used flashrom to update my bios.
> My motherboard is gigabyte GA-G33-DS3R, lspci attached.
> I used:
> flashrom -c MX25L8005 -w g33ds3r.f7h

That's interesting. This command does write to the chip without erasing
first, so the image you now have in ROM is supposed to be a mixture of
the old and new BIOS. If you haven't tried rebooting yet, I'd advise
Please try to verify the image you just wrote before rebooting.

> as it had that chip (1024K) and another unknown one (0K).

Yes, known quirk, will be fixed in the near future.

> It took around 1 minute. 
> btw, that worked on linux, but on linux 2.6.26 (which I need
> for other device support), I get: 
> # flashrom -r bios.bin
> Calibrating delay loop... OK.
> No coreboot table found.
> Found chipset "Intel ICH9R", enabling flash write... Can't mmap memory using /dev/mem: Invalid argument
> linux 2.6.26 has an option for filtering userspace access to /dev/mem, I
> tried both on and off but that didn't fix it.

Ouch. That would be a regression in Linux. Have you tried to report this
to the linux-kernel mailing list?



More information about the coreboot mailing list