[coreboot] flashrom on gigabyte GA-G33-DS3R : success!

Laurence Darby ldarby at tuffmail.com
Sun Jul 20 01:54:44 CEST 2008


So I took a huge leap of faith, and used flashrom to update my bios.
My motherboard is gigabyte GA-G33-DS3R, lspci attached.

I used:

flashrom -c MX25L8005 -w g33ds3r.f7h

as it had that chip (1024K) and another unknown one (0K).  

It took around 1 minute. 

btw, that worked on linux, but on linux 2.6.26 (which I need
for other device support), I get: 

# flashrom -r bios.bin
Calibrating delay loop... OK.
No coreboot table found.
Found chipset "Intel ICH9R", enabling flash write... Can't mmap memory using /dev/mem: Invalid argument

linux 2.6.26 has an option for filtering userspace access to /dev/mem, I
tried both on and off but that didn't fix it.


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: lspci.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080720/a83bc85a/attachment.txt>

More information about the coreboot mailing list