[coreboot] [PATCH] v3: Move default mainboard vendor/subsystem from Kconfig to dts

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Jul 11 14:36:07 CEST 2008

On 11.07.2008 13:59, Uwe Hermann wrote:
> On Fri, Jul 11, 2008 at 03:06:43AM +0200, Carl-Daniel Hailfinger wrote:
>>> My goal was to have the same name in the dts which is also used as
>>> variable name in C code. The existing code has a somewhat peculiar
>>> mapping from organic growth over time:
>>> mainboard-vendor -> const char *mainboard_vendor
>>> mainboard-name -> const char *mainboard_part_number
>>> If we can agree on whether the variable should be called
>>> "mainboard_name" or "mainboard_part_number", I'd be willing to prepare a
>>> patch.
> mainboard_name sounds good.

Indeed. The only problem is that this sort of conflicts with
CONFIG_MAINBOARD_NAME, but that Kconfig variable is misnamed anyway (it
contains the mainboard directory).

>> OK, here comes a patch which makes mainboard-vendor naming more consistent.
>> mainboard-name naming has been postponed because it's not clear what the
>> real name should be.
>> Generated code is identical to the state before the patch.
>> Signed-off-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>
> Acked-by: Uwe Hermann <uwe at hermann-uwe.de>
> Build-tested with a few targets.

Thanks, r694.



More information about the coreboot mailing list