[coreboot] SeaBIOS booting

Myles Watson mylesgw at gmail.com
Tue Jul 8 23:04:18 CEST 2008

> -----Original Message-----
> From: Kevin O'Connor [mailto:kevin at koconnor.net]
> Sent: Monday, July 07, 2008 5:47 PM
> To: Myles Watson
> Cc: Coreboot
> Subject: Re: [coreboot] SeaBIOS booting
> On Mon, Jul 07, 2008 at 11:52:21AM -0600, Myles Watson wrote:
> > >> I don't see anything unusual in the log.  Did all the OSes die in the
> > >> same way?
> > Yes.
> >
> > >> Did anything come up on the vga screen?
> >
> > I missed this question the first time.  Nothing comes up on the VGA
> > screen.  That was especially interesting to me because when I tried to
> > boot the Windows CD in qemu, if I press F12 for the boot menu, then
> > select 3. CD-ROM, it says Press Any Key to Boot from CD.....  If you
> > wait until all 5 dots are there, you can't press any key any more.  It
> > hangs.
> Hrmm - I don't see this on my machine.  Did you compile seabios
> yourself?  Maybe it's being miscompiled on your machine.  Can you try
> the elf at:

Same behavior.  What version of qemu are you using?  I'm using the patched
version of 0.9.0.

> http://linuxtogo.org/~kevin/SeaBIOS/bios.bin.elf-0.2.3
> > Maybe that's what's happening, maybe it's something else, I'm still
> looking.
> >
> > Does the lack of VGA output give any hints?  I have VGA output until
> > it jumps to the SeaBIOS, but nothing after that.
> It's very odd.  From your log:
>   Scan for VGA option rom
>   Running option rom at 000c0003
> That indicates that seabios found your vga rom and ran it.  I don't
> know why you wouldn't see seabios' output on the screen.

I tried a different boot CD (Knoppix), and it doesn't give me any output
until later in the boot process.  Once it gets to a certain point, the text
output appears, but it is only displayed in the top 5 lines of the screen,
and continues to display the coreboot boot messages everywhere else.  Once
Knoppix boots into the graphical mode, it works fine.

I'm thinking that the text output from the other CDs is getting lost.  I
tried turning on the debugging output from handler_10, but it is a lot to go
through.  I tried adding in a different video card, but it isn't getting
past the emulator.

> It can be pretty challenging to debug these problems.  The only thing
> I can think of that will help is to try and increase the debug levels
> in src/config.h.

It looks like the characters are getting passed to the video BIOS.  I don't
know why they get lost from there.

If you have any ideas for where to look next...


> I'm currently tracking down a boot failure with os/2 under qemu.
> Maybe the fix will improve booting on other OSes as well.
> -Kevin

More information about the coreboot mailing list