[coreboot] i82801xx nic problems.

joe at smittys.pointclark.net joe at smittys.pointclark.net
Wed Jan 30 18:53:13 CET 2008

Quoting Corey Osgood <corey.osgood at gmail.com>:

> On Jan 30, 2008 9:50 AM, <joe at smittys.pointclark.net> wrote:
>> Hello,
>> I am racking my brains with this. No matter what I do I can't seem to
>> get the nic working. The nic is onboard the i82801DB southbridge down
>> from the PCI bridge, so my Config.lb looks something like this:
>> device pci 1e.0 on # PCI bridge: Intel Corporation 82801 PCI Bridge
>> chip drivers/pci/onboard
>> device pci 08.0 on end # Intel Corporation 82801DB PRO/100 VE Ethernet
>> Controller
>> end
>> end
> I think your config is wrong, and at the very least, you don't need the
> "chip" line, unless you're loading a rom for it. Bear with me, I'm stuck in
> windows atm, but I'm pretty sure it's lspci -t that shows how the devices
> are connected. Might also be a good idea to look at the setup for another
> board, perhaps the intel jarrell or xe7501devkit has an onboard nic
I tried it with and without with no luck.

lspci -t

>> But no matter what I try coreboot thinks it is a static device and
>> disables it.
>> do_pci_scan_bridge for PCI: 00:1e.0
>> PCI: pci_scan_bus for bus 01
>> PCI: devfn 0x0, bad id 0xffffffff
>> PCI: devfn 0x8, bad id 0xffffffff
>> PCI: devfn 0x10, bad id 0xffffffff
>> PCI: devfn 0x18, bad id 0xffffffff
>> PCI: devfn 0x20, bad id 0xffffffff
>> PCI: devfn 0x28, bad id 0xffffffff
>> PCI: devfn 0x30, bad id 0xffffffff
>> PCI: devfn 0x38, bad id 0xffffffff
>> Disabling static device: PCI: 01:08.0
>> This wouldn't really be a problem if Linux detected it but that is not
>> even happening. I am really stumped here. I even tried loading the
>> Intel Boot Agent pci rom from the original bios but the same thing
>> happens. Help?
>> Thanks - Joe

More information about the coreboot mailing list