[coreboot] [ patch] v3 Geode graphics init.

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Fri Feb 22 02:48:05 CET 2008

On 22.02.2008 02:30, ron minnich wrote:
> On Thu, Feb 21, 2008 at 5:23 PM, ron minnich <rminnich at gmail.com> wrote:
>> On Thu, Feb 21, 2008 at 5:18 PM, ron minnich <rminnich at gmail.com> wrote:
>>  > Bad news. It is hanging (locking up) in vsm. I interpret this to mean
>>  >  it maybe took an interrupt? Post code is 0x10.
>>  >
>>  >  output is attached.
>>  Just to double-test I backed it out and rebuilt, and everything works again.
>>  Gee, this is gonna be fun :-)
> I spoke to soon. OK, something has introduced another regression.
> Sigh.
> Here is the pattern.
> You flash. Linux starts to boot. It thinks it finds an ACPI table. It
> coughs chunks and dies.
> The next time you boot, it hangs in vsm. Oh, yes, and power cycling
> does no help.
> I just tried leaving it off for one minute and ... it hangs in vsm.
> !@#$#@!$#@.

Can you try to find out if r613 is already broken? You tested that 
revision and it worked fine. I'm not trying to point blame, I just want 
to figure out how this could slip through reviews and tests.

> I'm a little concerned that we broke the lar zeroing code again. that
> would explain the bogus ACPI bits.
> we're breaking things too often. I think we may need to stop
> committing until we get a test. So we may need a signoff, "Tested-by",
> and no commits until that is seen.

Indeed. Stefan has a test rig. Maybe he could make that accessible to 
developers with commit rights to test new images.



More information about the coreboot mailing list