[coreboot] Dump GPIO I/O Registers

Corey Osgood corey.osgood at gmail.com
Thu Feb 21 08:46:00 CET 2008

On Thu, Feb 21, 2008 at 2:39 AM, <joe at smittys.pointclark.net> wrote:

> Sweet:-)
> With Stefan's great tool I think I found my ethernet enable GPIO!!
> I run it with the original bios (ethernet enabled) and then with the
> original bios (ethernet disabled). The only difference is in the 0x0C
> register looks like GPIO 23 is drivin to high (asserted), enabling the
> LAN Controller. This would have taken me forever to trace it manually
> without any schematics. For fun I ran it with the coreboot and yup the
> 0x0C register looks just like the original bios with ethernet
> disabled. There are alot of other differences with the coreboot one,
> should I be worried about those (one of them could have to do with my
> flashrom issues??)?
> Anyways, the question now is how can I assert GPIO 23 before the pci
> bus scan so coreboot will recognize my ethernet device?? Anyone??

Rather simple. Some time pre-ram init, set up the GPIO base, then use
inb()/outb() to modify the contents of the GPIO register you need to change.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080221/56b77b68/attachment.html>

More information about the coreboot mailing list