[coreboot] Weirdness with lzma setting in v3

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Sun Feb 10 13:07:43 CET 2008

On 10.02.2008 05:15, Myles Watson wrote:
>> On 08.02.2008 20:08, Myles Watson wrote:
>>> Sorry in advance that I only have time to report the problem.  If no
>>> one beats me to it I'll look into it a little more on Monday.
>>> Something goes wrong when lzma is enabled (which it is by default)
>>> I'm attaching my config which succeeds (nolzma.config), and the serial
>>> output from qemu using lzma and not.  For some reason, segment0 gets
>>> found twice when lzma is used?  Anyway, it doesn't find the devices it
>>> should and dies.
>> Very weird. It worked for me, but I always issue a make distclean before
>> configuring.
>> I just tried the default coreboot config again (make distclean; make
>> menuconfig; (exit and save)) and my log (with lzma) looks exactly
>> (except for different compression) like your working log (without lzma).
>> Having the failing .config would help a lot. The failing ROM would also
>> be interesting (please don't send that to the list, upload it somewhere
>> instead).
> The failing .config is in mainboard/emulation/qemu-x86/defconfig

Boot log with defconfig attached. Works for me.

> It's the same (except for ROM Size) as the one you got (hopefully.)
> I'll put the ROM somewhere else if it still fails for me on Monday.  It's
> possible that it's buildrom's problem.  I haven't tried the ROM without
> adding the payload.

I usually don't use buildrom for my tests and I don't specify a payload.
That saves a lot of time for the stuff I'm working on.

If you manage to reproduce with a non-buildrom coreboot build with only
a single instance of make (no "make -j"), we should indeed investigate.
Right now I'd say the archive is corrupted/contains garbage. This should
be verifiable with "lar -l coreboot.rom".
The next step would be to find out how the archive ended up that way.
Multiple lar instances working on the same archive at the same time?
Parallelization issues? RAM/disk corruption?



-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: bootlog_emulation_qemu-x86.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20080210/4d7dce14/attachment.txt>

More information about the coreboot mailing list