[coreboot] Weirdness with lzma setting in v3

Myles Watson myles at pel.cs.byu.edu
Sun Feb 10 05:15:36 CET 2008

> On 08.02.2008 20:08, Myles Watson wrote:
> > Sorry in advance that I only have time to report the problem.  If no
> > one beats me to it I'll look into it a little more on Monday.
> >
> > Something goes wrong when lzma is enabled (which it is by default)
> >
> > I'm attaching my config which succeeds (nolzma.config), and the serial
> > output from qemu using lzma and not.  For some reason, segment0 gets
> > found twice when lzma is used?  Anyway, it doesn't find the devices it
> > should and dies.
> >
> Very weird. It worked for me, but I always issue a make distclean before
> configuring.
> I just tried the default coreboot config again (make distclean; make
> menuconfig; (exit and save)) and my log (with lzma) looks exactly
> (except for different compression) like your working log (without lzma).
> Having the failing .config would help a lot. The failing ROM would also
> be interesting (please don't send that to the list, upload it somewhere
> instead).

The failing .config is in mainboard/emulation/qemu-x86/defconfig

It's the same (except for ROM Size) as the one you got (hopefully.)

I'll put the ROM somewhere else if it still fails for me on Monday.  It's
possible that it's buildrom's problem.  I haven't tried the ROM without
adding the payload.


> Regards,
> Carl-Daniel
> --
> http://www.hailfinger.org/

More information about the coreboot mailing list