[coreboot] Error Compiling Coreboot v1 for Acer WT300

Holden Hao holdenhao at gmail.com
Thu Dec 11 06:59:10 CET 2008


I am trying to build a Coreboot v1 BIOS with an Etherboot payload for
an Acer WT300 thin client.  Somebody was already successful in running
LinuxBIOS with etherboot on it. (
http://spritesmods.com/?art=wtcluster ).  I have tried to contact the
person on the website already but he has not replied to me.  So I am
trying out Coreboot myself.

The Acer WT300 has a board similar in specifications to a Supertek
ST3WT.  The chips on the board are CS5530A and PC973717. My build
system is Debian Etch and CentOS 5.  I have tried building sample
images using default config files but all my efforts failed.  I was
able to run the python script but I did not get far running make.  I
get the errors below:

cp /home/holden/src/coreboot-v1/src/arch/i386/config/crt0.base crt0.S
gcc -x assembler-with-cpp -DASSEMBLY -E ... crt0.S > crt0.s
/bin/sh: -c: line 0: unexpected EOF while looking for matching `''
/bin/sh: -c: line 1: syntax error: unexpected end of file
make: *** [crt0.s] Error 2

I get the same errors in Debian and CentOS for all config files I have
tried.  The error above is the same as the one reported on the link


I hope somebody can help me with the problem.  I have about 10 of the
Acer WTs that I hope to use as Linux Thin Clients.  The units will be
used for our organization's (a LUG called DabaweGNU) computer lab.



More information about the coreboot mailing list