[LinuxBIOS] Gigabyte M61P-S3 board

Michael van der Kolff mvanderkolff at gmail.com
Sat Sep 29 05:36:16 CEST 2007

Well, I was just inspecting this beautiful little M61P-S3 board, and
it has an SPI flash chip on it, in particular, the MX25L4005A.  I
don't seem to see anything that would indicate that anything but the
IT8716F would be connecting to it.

I first tried using the version in Debian (testing):  It didn't detect
any flash chip.

I then tried using the SVN version: It too didn't detect anything.

Then I looked through, and found a reference to the M55.  I looked the
archives, and found a message from May07:  I figured I would see if I
could get lucky telling it to look like an M55.

I first got the connection to the IT8716F working, by telling it that
the M61 is just like an M55, except with PCI device id 0x03e0.  That
seemed to work.

However, going from there, it doesn't seem to detect any SPI
functionality at all.

It looks to me like support for each flash chip is needed (given that
the spec sheet gives commands to output the manufacturer ID & device
ID), but maybe that isn't true.  In any case, the command set is
relatively simple.

Is the SPI stuff properly supported?  I feel like I'm a little out of
my depth on this code...



More information about the coreboot mailing list