[LinuxBIOS] badly initialized (?) pci bridge on the M57SLI (with irq table and mptable)

yhlu yinghailu at gmail.com
Tue Sep 25 01:23:35 CEST 2007

On 9/24/07, Uwe Hermann <uwe at hermann-uwe.de> wrote:
> On Thu, Sep 20, 2007 at 09:44:33AM -0700, yhlu wrote:
> > please try to move
> >
> > RES_PCI_IO, PCI_ADDR(0, 1, 0, 0x78), 0xC0FFFFFF, 0x19000000,
> >
> > from
> > ctrl_conf_master_only
> > to
> > ctrl_conf_mcp55_only
> Nice, thanks!
> That fixes the problem for me on the MS-7260 (K9N Neo), which is
> MCP55-based. I verified that a PCI VGA card works fine in any of
> the three PCI slots.
> I'll post a patch in a few minutes. Can you give us a good commit
> message for this? What exactly does the fix do and why?

you can say:
pci bridge decoding change.

> Btw, I also tried a PCI NIC which did not always work, I was seeing some
> funny effects; it worked in slot 1 when I first tried the patch, but not
> in slot 2 or 3. Later I couldn't reproduce it working in slot 1 either.
> This may be NIC-related or a problem in the emulator (?) as the VGA card
> I mentioned above works fine in every slot (and reproducible, I tried
> booting multiple times for each slot).

current only VGA option rom need emulator...
other card doesn't need that..., so these card can be used on platform
other than x86.
option rom always do:
1. setup screen: like dos application
2. silicon workaround...?: could be done in OS driver...
3. download fw in the controller, and start controller ===> like
cheap/low end lsi scsi card...
So we don't need it.

what is the PCI/NIC? or you can add dummy driver for it to skip option
rom execution or modify the framework only do option rom to vga class.


More information about the coreboot mailing list