[LinuxBIOS] #35: Make it possible to boot Windowsusing LinuxBIOS

Myles Watson myles at pel.cs.byu.edu
Fri Oct 26 18:52:36 CEST 2007

> On Fri, Oct 26, 2007 at 10:25:39AM -0400, Tom Sylla wrote:
> > On 10/26/07, LinuxBIOS <svn at openbios.org> wrote:
> > >  Mostly works now, the exact status and a tutorial is available at
> > >  http://linuxbios.org/Booting_Windows_using_LinuxBIOS
> >
> > Is it working on *real* hardware?

Not for me yet.

> Any updates on the current ADLO/Windows status? I didn't follow those
> threads too closely. I also think there are some patches pending for
> either review or committing (please repost for easier review and more
> exposure, thanks).

You can get closer now than before by 
1. Checking out the latest Bochs BIOS from CVS (1.1.87 from 10/14/2007)
2. Patching it so it doesn't initialize the keyboard twice and sends debug
to the serial port (rombios.patch)
3. And using the generated BIOS-bochs-legacy file as the payload for ADLO.

The latest Bochs BIOS has 
1. Updated delays (no more counting to 0xff before saying the disk is too
2. Updated media detection for CDs
3. Improved support for large (> 8GB) Hard drives

I also use a patched loader which sets the CMOS values a little differently

It still fails to boot in QEMU for me.  It installs and reboots, then fails
due to an incorrect checksum of the installed files.  I've tried NTFS and
FAT, flat and sparse files ... suggestions welcome.

In AMD's simulator SimNow, it installs, reboots, then flashes the cursor
different colors and stops (I think it's because the PIT isn't set up)

My s2892 does the same thing but with a progress bar (gets half way done,
flashes white, then blue, then amber)

I've decided to try to use Linux as a Bootloader so that the hardware
(including the PIT) gets initialized completely before loading ADLO.  I am
working through some other things to get there, so I haven't made much
progress on Windows booting lately.

I'd also like to include the PCI BIOS features of Bochs' BIOS, and pass ACPI
tables, e820 tables, etc... but I don't know how much work that really is.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: rombios.patch
Type: application/octet-stream
Size: 983 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071026/a9404d18/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: loader.patch
Type: application/octet-stream
Size: 998 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071026/a9404d18/attachment-0001.obj>

More information about the coreboot mailing list