[LinuxBIOS] badly initialized (?) pci bridge on the M57SLI (with irq table and mptable)

Ward Vandewege ward at gnu.org
Tue Oct 16 16:30:02 CEST 2007

Hi Harald,

On Tue, Oct 16, 2007 at 04:19:06PM +0200, Harald Gutmann wrote:
> Am Montag, 15. Oktober 2007 21:56:47 schrieb Harald Gutmann:
> > i tried that patch today, but it doesn't help to geht pci-slots working on
> > my board, which is a rev.2.0.
> seems that i've patched in the wrong directory (src not work).
> the patch works for one slot.

OK, thank you for that confirmation, that means that we now have 3 people
with 2 different revisions of the board that report that this patch fixes one
pci slot.

I suggest we add the patch to the main tree.

Florentin, do you want to make a patch with signed-off-by? I'll be happy to
ack and commit it.

> i patched both lines, also the one for GPIO40:
>  RES_PORT_IO_8, SYSCTRL_IO_BASE + 0xc0+38, 0x00, 0x68,/* GPIO39 PCI_GNT3 */ \
>  RES_PORT_IO_8, SYSCTRL_IO_BASE + 0xc0+39, 0x00, 0x68,/* GPIO40 PCI_GNT2 */ \
> at the first boot with my pci-soundcard and an 3com nic, in lspci both devices 
> showed up, but the nic didn't work. (i'm sorry, but i don't have the log from 
> dmesg any more. something with probe pci and -22 appeared there.
> but after that all, it just works the first slot. my soundcard is also not 
> recogniced in the second slot. (but both slots work with propritary bios.)

I tried that too, and got similar results - it does not fix the second pci
slot. I have a few other things I want to try based on the pci io dump, but I
have not had time yet. And there is the matter of the sticky bit that we have
not resolved...


Ward Vandewege <ward at fsf.org>
Free Software Foundation - Senior System Administrator

More information about the coreboot mailing list