[LinuxBIOS] EHCI stack to port to FILO?

Corey Osgood corey.osgood at gmail.com
Mon Oct 1 05:03:34 CEST 2007

Peter Stuge wrote:
> On Sun, Sep 30, 2007 at 04:08:56PM -0400, Corey Osgood wrote:
>> I'm working from the 2.6 kernel driver at the moment,
> What about the early serial stuff? (Not debug port, but the other.)
> Maybe there's some EHCI stuff there?

You mean in the kernel or LB?

>> And can anyone, perhaps with an EPIA or EPIA-M, confirm that UHCI
>> is working in FILO? I've tried disabling the EHCI device, but it
>> still fails on vt8237.
> All EHCI controllers also provide one UHCI or OHCI (I forget if
> there's a choice or if not, which it should be) per physical port in
> order to have backwards compatibility for 1.x-only devices.
> So you should find UHCI controller devices when EHCI is enabled. And
> if you disable EHCI, the UHCI/OHCI controllers should be disabled
> too.

Hmm, vt8237r has a separate device for EHCI that can be disabled without
disabling the UHCI controllers. I'm assuming that this essentially makes
them act as regular UHCI controllers.

> Try plugging a low- or full-speed device into the controller.

Just tried it:

boot: uda1:/vmlinuz root=/dev/hda1 console=ttyS0,115200n8
earlyprintk=ttyS0,115200n8 ro            
LinuxLabs USB bootloader
New USB device, setting address 2
New USB device, setting address 2
New USB device, setting address 2
There is a USB device, but it won't init! This is a bad thing.

I'll try to disable EHCI and then use the 1.1 hard drive adapter, and
see what happens.


More information about the coreboot mailing list