[LinuxBIOS] Booting Windows with QEMU+LinuxBIOS

Jun Koi junkoi2004 at gmail.com
Thu Nov 29 10:37:10 CET 2007

Hmm... I managed to do like this:

- Compile ADLO separately, then I have a file named "payload"
- In LinuxBIOSv3, I run "make menuconfig", then specify the path of
payload option to the above "payload".
- Save options, quit and compile.

As a result, I have build/bios.bin, and I overwrites this file onto
the original bios.bin of my QEMU.

Then, I run QEMU with my Linux image. It works, and I can login to my
Linux QEMU.

Now, the problem is that I am not sure if my Linux on QEMU really uses
LinuxBIOS. How can I confirm that? "dmesg" doesnt seem to return
anything special to me.

Thank you,

On 11/29/07, Jun Koi <junkoi2004 at gmail.com> wrote:
> Hello,
> I am playing around with LinuxBIOS. The first step is to boot Windows
> on QEMU+LinuxBIOS. I follow the steps in
> http://www.linuxbios.org/Booting_Windows_using_LinuxBIOS, and do with
> LinuxBIOSv3. However, in the documentation, I read:
> .....
>   Building LinuxBIOSv3
> Now it is time to build linuxBIOSv3. You should first download it:
> $ svn co svn://linuxbios.org/repository/LinuxBIOSv3
> $ cd LinuxBIOSv3/util
> $ svn co svn://linuxbios.org/repos/trunk/LinuxBIOSv2/util/ADLO
> $ Apply patch that puts ADLO into LinuxBIOSv3
> $ make menuconfig
> ....
> I just dont see how to "apply the patch to put ADLO into LinuxBIOSv3".
> ADLO was checked out from SVN, but it is a directory, so how can we
> "apply patch ...." as in the instructions?
> Thanks,
> Jun

More information about the coreboot mailing list