[LinuxBIOS] Can't compile flashrom

Corey Osgood corey.osgood at gmail.com
Sun Nov 25 19:45:34 CET 2007

Shocky wrote:
> Hi,
> I'm new to LinuxBios, and just looking for a way to flash the bios on an HP 
> laptop without installing Windoze. None of the tricks I've found through 
> Google have worked for me so far, including HP's own utility for making 
> bootable usb keys.

Some HP laptops these days use SPI flash, which flashrom can do only in
one special situation (afaik), Gigabyte m57sli. Also, the flash may have
protection coming from the embedded controller or GPIO lines, which
flashrom knows nothing about.

Last time I flashed my HP laptop's bios, I took a windows 98se iso,
added the bios and flash utility to it with an iso editor, and then
burned and booted from it. I ran the utility through dos, and it worked
fine. This should also work fine with a custom cd and the floppy
emulation, with a 98se boot disk as the source. K3b can do the dirty work.

> I'm trying to compile just the flashrom component of LinuxBios from svn, but 
> make gives me an error telling me that I need to install pciutils-devel and 
> zlib-devel. The problem is these packages are already installed. 
> I extracted the little .test.c program from the Makefile, and determined that 
> the linker is unable to resolve the call to pci_alloc. The problem is I don't 
> know why. The header is there in /usr/include/pci/pci.h, 
> and /usr/lib/libpci.a is there (but I don't know how to tell what symbols the 
> library provides; reached the limit of my expertise there).
> This happens on two different machines, one running Mandriva 2008.0 (the 
> laptop in question), and the other Mandriva 2007.0 (my desktop pc). Any ideas 
> what's going on and how to resolve it?

Sorry, can't be of much help.


More information about the coreboot mailing list