[LinuxBIOS] Mounting root FS from VIA EPIA M-II still not working

Russell Whitaker russ at ashlandhome.net
Tue Nov 20 04:01:21 CET 2007

On Sun, 18 Nov 2007, Coquelicot wrote:

> Dear all,
> I know that this subject is coming back and forth to the mailing list
> like boomerang but I need some help with it. Apparently it IS possible
> to make linux recognize CompactFlash as a root device but so far I
> have been unable to make it work. I have tried lots of paths, both
> from reading the mailing list archives (esp. one success story from
> Markus Tornqvist - which gave me some hope) and VIA EPIA M howto
> available on LB webpage. I still can't make Linux recognize 3rd IDE
> controller (ide2). LinuxBIOS part works fine - the kernel boots from
> CF card all right, than it stops.

Was there a kernel panic message when it stops?
The kernel might be reporting the CF card as /dev/sda and the first
partition as /dev/sda1. If so, do you have scsi support compiled in
the kernel?  Also, check your bootloader's configuration.


More information about the coreboot mailing list