[LinuxBIOS] Mounting root FS from VIA EPIA M-II still not working

Coquelicot coquelicot408 at gmail.com
Sun Nov 18 14:01:25 CET 2007

Dear all,

I know that this subject is coming back and forth to the mailing list
like boomerang but I need some help with it. Apparently it IS possible
to make linux recognize CompactFlash as a root device but so far I
have been unable to make it work. I have tried lots of paths, both
from reading the mailing list archives (esp. one success story from
Markus Tornqvist - which gave me some hope) and VIA EPIA M howto
available on LB webpage. I still can't make Linux recognize 3rd IDE
controller (ide2). LinuxBIOS part works fine - the kernel boots from
CF card all right, than it stops.

I have tries 'resetcf' LB utility in early stage of boot (I am trying
to boot Debian so I was putting this utility in various directories in
the initrd image - 'init-premount', 'init-top', also - 'local-top'. I
tried to pass 'ide2=0x1e0,0x1ec,9 ide4=noprobe'. Nothing worked.

I know that plan B for now is to try to find CF-to-IDE adapter that
can do the booting but I thought that would be a waste of CF slot on
board... I wanted to make the system as embedded as it can be.

I will be very grateful for any advice. I am using kernel 2.6.23, my
CF card is SanDisk Extreme III.


More information about the coreboot mailing list