[LinuxBIOS] lzma compression and filo/etherboot payloads in buildrom

Myles Watson myles at pel.cs.byu.edu
Thu Nov 15 21:11:27 CET 2007

> I seem to have a problem when trying to use a lzma pre-compressed payload
> in
> buildrom in combination with an etherboot (or filo) payload. Things work
> fine
> with a kernel or LAB payload.
> I've attached the LinuxBIOS Config.lb I used, and the boot output for
> etherboot. I recall having similar problems with a filo payload.
> in Config.lb and disable the LZMA compression in buildrom's kconfig the
> Etherboot payload works just fine.

I just tried it with serengeti_cheetah, and it worked for me with just a
fallback image. I've attached my Config and bootlog.

I noticed that you have CONFIG_COMPRESSED_PAYLOAD_LZMA and
CONFIG_PRECOMPRESSED_PAYLOAD set in your Failover image, even though there
is no official payload.

I couldn't see anything else, but I hope this helps.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: Config.filoLZMA.lb
Type: application/octet-stream
Size: 656 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071115/8a734477/attachment.obj>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: bootlog.txt
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20071115/8a734477/attachment.txt>

More information about the coreboot mailing list