[LinuxBIOS] [PATCH] Add initial serial output for Via vt82c686

Corey Osgood corey_osgood at verizon.net
Sun Mar 11 07:45:42 CET 2007

Hold off on committing this. I'm having problems with LinuxBIOS hanging 
after entering protected mode (according to the post code). This isn't 
what's causing it, I've dumped in more post codes to check it, but until 
I've got it worked out, please hold off. I could have sworn I tested 
this after a cold reboot, but I guess I only did a reset. Also, I 
submitted the wrong patch the second time, I didn't quite fix 
everything, so there will be another.

Anyone have any idea what causes a hang after protected mode? Is it 
possible that it's because I'm trying to run a dual p3 system with only 
use one cpu? I'm pretty much lost, because it's never even getting into 
auto.c's main(), so it must be in my Config.lb or Options.lb, but I have 
no clue where. I've attached both of these, and I've tried testing with 
only one cpu installed, to no avail.


More information about the coreboot mailing list