[LinuxBIOS] Distros

joe at smittys.pointclark.net joe at smittys.pointclark.net
Thu Mar 8 06:57:36 CET 2007

Quoting Corey Osgood <corey_osgood at verizon.net>:

> joe at smittys.pointclark.net wrote:
>> No, I think I am going to just try Gentoo though. It's time for a    
>> change, I have been using Fedora/Redhat for many years. And I have   
>>  heard great things about Gentoo.
>> Thanks - Joe
> Well, just for the record, I've intalled FC6 x86 in QEMU from the DVD
> iso, and tried both with and without SELinux enabled, and I had
> absolutely no build errors on several targets (via epia, asus p2b, and
> a couple tyan boards). I didn't even have to turn off stack protectors,
> and this is a fully updated system. I'm not sure where your error was
> coming from or even what it was, sorry. Enjoy Gentoo, cya again in a
> week or so when you're done compiling the base system ;)
> -Corey

Hmm very strange. Both Ron and I tried it on FC5 and FC6 with no luck??
This was the error:

cp linuxbios_ram.nrv2b linuxbios_ram.rom
echo '/*ldoptions*/' > ldscript.ld; cat ldoptions >> ldscript.ld ; for
file in  /root/LinuxBIOSv2-2564/src/arch/i386/init/ldscript.lb
/root/LinuxBIOSv2-2564/src//arch/i386/lib/id.lds ; do echo /\* $file
\*/ >> ldscript.ld; cat $file >> ldscript.ld ; done
gcc -m32 -nostdlib -nostartfiles -static -o linuxbios -T ldscript.ld crt0.o
nm -n linuxbios | sort > linuxbios.map
objcopy --gap-fill 0xff -O binary linuxbios linuxbios.strip
objcopy: linuxbios.strip: Bad value
objcopy: linuxbios.strip: Bad value
make[1]: *** [linuxbios.strip] Error 1
make[1]: Leaving directory
make: *** [normal/linuxbios.rom] Error 1

Maybe I will try a fresh install of FC6???

Thanks - Joe

More information about the coreboot mailing list