[LinuxBIOS] flashrom: Doesn't seem to be able to write on ICH-2 (maybe other ICH-x) mainboards

mmilburn at nmt.edu mmilburn at nmt.edu
Sun Jun 24 04:45:11 CEST 2007

Hello Uwe,
I have recently tried to use flashrom on two different ICH-6 based
motherboards.  As described in your original posting, detection and
reading of the chips works.  Each of the boards I've worked with (ASUS
P5GD2-X, ASUS P5GD1-VM) use a winbond W83627EHF chip to communicate with
the flash chip.
I have not attempted to use uniflash on these boards for two reasons:
A)  the winbond chips supported (by uniflash) are not register compatible
and do not use exactly the same communication scheme as the
W83627EHF/W83627EHG chips.
B)  the chipset enabling code seems to perform the same operation with the
exception of not poking at the firmware hub decode enable register
(uniflash seems to do this, though my pascal is shaky).
I've been poking at the winbond chip and though I've sucessfully gotten it
to hide the flash chip, I have yet to figure out what bit I'm forgetting
to flip to allow writes to ROM.

In reference to:

-mark milburn

More information about the coreboot mailing list